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What is SoftPhone? 
SoftPhone is an add-on service. It gives you the freedom to make and receive phone calls 
through your laptop or desktop computer.  Simply download and install the application and talk 
from virtually anywhere! 
 
SoftPhone is completely separate from your Lingo line. SoftPhone has a different phone number, 
different call forwarding settings, different voice mail, etc… 
 
You will also need a headset with a microphone (not included with Lingo SoftPhone service). 
 
SoftPhone Features: 

• Anonymous Call Rejection 

• Authentication 

• Basic Call Logs  

• Caller ID with Name 

• Call Forwarding Always 

• Call Forwarding Busy 

• Call Forwarding No Answer 

• Call Forwarding Selective 

• Calling Line ID Delivery Blocking 

• Call Return 

• Call Transfer 

• Call Waiting 

• Call Hold 

• Do Not Disturb 

• External Calling Line ID Delivery  

• Internal Calling Line ID Delivery 

• Last Number Redial 

• Simultaneous Ring  

• Speed Dial 8 

• Voice Messaging User 

• Outlook Contact Integration 

• Three-Way Calling 
 

System Requirements 
As with Lingo, you will need a high speed Internet connection and a PC with the following system 
requirements: 
 

• Minimum Pentium III processor 

• Minimum 128 MB of total system memory 

• Minimum 20 MB hard disk space for installation 

• Java Runtime 1.5* 

• Windows XP or Windows 2000 
NOTE: SoftPhone is NOT compatible with Windows Vista or Macs. 

 
 
 
 
*SoftPhone requires Java Runtime Environment version 1.5 (JRE). During the installation process 
you may get a JRE error when you attempt to open the SoftPhone.exe file.  
 
If you receive a runtime error, you can manually download the Java runtime environment here: 
http://java.sun.com/products/archive/j2se/5.0_10/index.html 
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1. Go to the bottom link for JRE (JRE 5.0 Update 10). 
2. Click “Download JRE”, you will be taken to the download page. 
3. Select either of the first two Windows options.  

 

Download and Install SoftPhone  

1. Login to your Lingo account.  
2. Click on "My Plan".  
3. Click on "Download SoftPhone".  
4. Scroll to “Download and Install SoftPhone” and click on and install the file. 
5. You will now see the SoftPhone installation wizard. 
6. Follow the setup instructions for each step, continue clicking through the Wizard until you 

reach the end, then you will be ready to launch the application. 
7. Click “Finish” to complete the Wizard. 

 

 

 

 

 

 

 

 

 

 

 

 

Login to SoftPhone 
Double-click the SoftPhone icon from your desktop or go to the Start Menu > Programs > Lingo 
SoftPhone to open the SoftPhone application. 

 
Windows Security Alert 
To help protect your computer, Windows Firewall may block programs and display a message 
giving you the option of unblocking the program. Should this occur on your computer, check 
“Unblock”.  
 
Once you sign in to SoftPhone, go to the help menu to login (Help > Sign In). You have the option 
of saving your information so that you do not have to fill it out every time you open SoftPhone. 
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User ID: SoftPhone user ID is your Lingo username followed by “_sp@lingo.com” such as 
“jsmith_sp@lingo.com” 
Password: Same as your Lingo password. 
 

Login Errors 
See below for common login errors and how to troubleshoot. Contact Customer Care if you 
encounter other errors and you are unable to troubleshoot.   
 

1. “Auto provision failed” > This means your PC has no network connectivity. 
2. “User is not found on Network Server” > You need to add domain name to your 

username (“@lingo.com”). 
 

SoftPhone Interface 
 
The SoftPhone screen has four tabs: 

• Home 

• Contacts 

• Call Logs 

• Active Calls 
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Home Tab 

 
1. Menu Bar 

The Menu Bar has five menu options: File, View, Action, Tools, and Help.  
 

2. Home Tab 
Make phone calls from this tab. Voicemail message count can be seen on this page, click 
on the “envelope” icon for quick access to the voicemail box.  
 

3. Dial Pad 
The dial pad is used for making phone calls.  
 

4. Status Bar 
Displays the current call status. 
 

5. Number Entry Box 
This box is used to make a new call.  Type in the numbers in the box with the  
 
keyboard or dial pad. View previously called numbers by pressing the down arrow icon. 
 

6. Call Button 
After entering a number in the number entry box, click on the Call button to make a new 
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call. 
 

7. Mute Button 
 

8. User Status 
Three status options: manual answer, auto answer and do not disturb. Select and inform 
calling parties about calling status. 
 

9. Quick Dial Icon 
Links to the Home Tab, click here to make a new call using the dial pad. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 -Page 8 of 14-  

Contacts Tab 

 
1. Contacts Tab 

Displays contact lists that can be used to make a call. 
 

2. Outlook Tab 
Displays Outlook contact list. To import contacts from Outlook, go to Tools and select 
Import Outlook Contacts.   
 

      3.  All Contacts 
Displays all contacts and detailed information. 
 

4.  Refresh 
Refreshes contact list with updated information. 

  
5. Quick Search Contact 

Use to search for a particular contact. 
 

6. Add Contact 
Use to add a new contact. 
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Call Logs Tab 

 
1. Call Logs Tab 

Displays details about calls, missed calls, received calls and outgoing calls. 
 

2. All Calls 
Displays all calls. 
 

3. Missed Calls 
Displays missed calls. 
 

4. Received Calls 
Displays incoming calls. 
 

5. Outgoing Calls 
Displays outgoing calls. 
 

6. Refresh 
Refreshes all call logs. 
 

7. Call Icon 
Make a call by clicking on the yellow phone icon beside a contact. 
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Active Calls Tab 
All active call information is available from this tab. After a successful call is established, 
SoftPhone displays the Active Calls tab. 
 
SoftPhone Calls 
 

Make a Call 
After logging in to SoftPhone, you will be placed on the Home tab.  The Home tab consists of a 
dial pad, a drop-down menu to enter telephone numbers, a CALL button to make a call, a 
messages indicator, and a call log.  
 
There are two different ways to make an audio call, by using the dial pad to select the telephone 
number to dial, or by clicking on the drop-down menu and entering the telephone number using 
the key pad on the keyboard.  
 

To make an audio call using the dial pad:  

1. Using the mouse on your computer, click on the dial pad, select a ten-digit number.  

If you want to make an international call, you need to add the international 
country code (011 + country code + number). For example, if calling the UK, you 
would dial (011 44 + number). 

2.  Click the CALL button to place the call.  

 

To make an audio call using the key pad on the keyboard:  

1. Using the key pad on the keyboard, select a ten-digit number to dial.  

If you want to make an international call, you need to add the international 
country code (011 + country code + number). For example, if calling the UK, you 
would dial (011 44 + number). 

 

2. Click the CALL button to place the call.  

Whichever way the audio call was initiated and after the CALL button has been 
clicked, the audio call will be placed.  

 
The Home tab switches to the Active Calls tab; a line appears, showing the audio call that has 
been initiated, and displaying the number that has been dialed.  
 
Once the other party answers the call that had been initiated earlier, the status of the call  
changes from Ringing to Active.  Active means that both parties are on a call.  
 
After a call becomes Active, the line appearance of the call displays several options to  
 
control the call.  These options are HOLD, TRANSFER, and HANG-UP.  HOLD enables the call 
to be place on hold, TRANSFER enables the call to be transferred to another party, and HANG-
UP enables the initiated call to be terminated.  
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Multiple Call Appearances  
SoftPhone lets you have multiple calls active (all but one on hold) at any time.  This feature only 
works if Call Waiting is turned on. 
 

Three-Way Calling 
Talk with two contacts at the same time with three-way calling. Place a call to the first contact. 
 
While talking to the first contact, the second contact will call you and you will receive a pop up box 
giving you the option to answer or ignore the incoming call. By selecting “Answer” the original call 
is automatically placed on hold and the new incoming call becomes the active call.  
 
To start a three-way call select the conference button for the active call. The second call is still on 
hold waiting for you to add him to the conference, click “conference” to start three-way calling. 
 
You can also be on a call, put it on hold, then call a second number and start three-way calling. 
 
The call will continue if one of the two contacts hangs up, but the call will terminate if you hang 
up. 
 

Answer an Incoming Call 
 

1. When an incoming call comes in, an alert message appears. 
2. To answer the call, click Answer or to ignore the call, click Ignore.  
3. If you answer the call, it becomes active.  

 

Place an Active Call on Hold 
Once a call has been initiated, the call can be placed on hold.  Under the line appearance for an 
Active call, there is a HOLD button that if clicked, places the Active call on hold.  
 
After the HOLD button has been clicked, the Active call is placed on hold.   
 
After the HOLD button has been clicked, the calling party is placed on hold and then the line 
appearance status changes from Active to Hold.  (Note that when a call is on hold, the Transfer 
button is not available.)  
 
To take the call off hold, click ANSWER.  The party that was placed on hold is brought back and 
the line appearance becomes Active again.  
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Transfer a Call 
During an Active call, the call may be transferred to another party.  Under the line  
 
appearance of an Active call there is a TRANSFER button, which if clicked on, opens a second 
window that enables the call transfer.    
 
After the TRANSFER button has been clicked, the Active call is placed on hold and the Transfer 
Call window opens.  
 
The Call Transfer window enables you to place the calling party on hold and transfer the party to 
another end point.  There are two ways to determine where to transfer the call to:  

1. You can select a contact to transfer the call to, by selecting a contact from the All 
Contacts box.  

2. You can use the key pad on the keyboard and enter the telephone number manually 
into the Number box.  

After selecting a party, indicating where the call will be transferred, you can transfer the call in two 
ways.  The two ways of transfer are:  

 

Blind Transfer  

Once a contact has been selected to transfer the call to, click the SEND DIRECTLY TO 
button in the Call Transfer window to transfer the call to the selected party.  This is 
considered a blind transfer.  
 

Consultative Transfer  

To initiate a consultative transfer, first select the contact you want to transfer the call to, 
but instead of clicking on the SEND DIRECTLY TO button which will initiate a blind 
transfer, click the CALL button.  By clicking the CALL button, the selected contact end 
point will ring.  Once the selected contact answers and if the party is ready to accept the 
transferred call (agreed over phone), then you can click the TRANSFER button to 
transfer the call.  This is called a consultative transfer.  
 
Once the call has been transferred, the call appearance disappears from the Active Calls 
tab.  
 
Note that when there is a consultative call in the Active Call tab, the call is converted to 
audio even if the user has multimedia features.  
 
The Call Transfer window has a search option that is used to quickly find a contact and 
transfer the call to that particular person.  

 
Volume Control 
To adjust the call volume go to the Windows Start Menu > All Programs > Accessories > 
Entertainment > Volume Control. 
 
 
 
 
 
 
 
 
 
 



 

 -Page 13 of 14-  

Voice Message Portal 
SoftPhone provides a count of voice messages that are waiting for the user in the voice message 
portal.  To dial the voice message portal, simply click on the mail envelope icon next to the 
message count.  SoftPhone automatically places a call to the voice message portal with the 
respective user number.  

 
Search for a Contact 

1. To search for a contact, click the Contacts tab.  

 At the bottom of the Contacts tab window there is a sub menu called Quick Search 
Contact.  

2. Enter the full name or first few letters of the name to see the results displayed in the 
contacts window.  

 
Add a Contact  

1. To add a contact, click the Contacts tab.  

2. Select the Add Contact.  

3. Enter the contact’s name and telephone number.  

4. Once the required information has been entered, click the Add Contact button to add 
the contact.  

To verify that a contact was added, check the Contacts window where it shows the new 
contact information.  
 

Click-To-Dial 
The Click-to-Dial functionality can be initiated from any contact in the Contacts tab.  For example, 
click the Contacts tab and then click the OUTLOOK button to view all Outlook contacts.  Beside 
each contact there will be an icon of a telephone handset.  When this icon is clicked, a call will be 
initiated to the intended party.  

 
View All Call Logs 
To view all calls, that is, missed calls, received calls, and outgoing calls, select the Call Logs tab, 
and then select the ALL CALLS button to view all calls that have been received through 
SoftPhone. Click on the phone icon to dial the number for a particular call log entry. 
 
View Missed Calls 
To view all missed calls, select the Call Logs tab, and then select the MISSED CALLS button to 
view all calls that have been missed.  Click on the phone icon to dial the number for a particular 
call log entry.  
 
View Received Calls 
To view all received calls, select the Call Logs tab, and then click the RECEIVED CALLS button 
to view all calls that have been received.  Click on the phone icon to dial the number for a 
particular call log entry. 
 
View Outgoing Calls 
To view all outgoing calls, select the Call Logs tab, and then select the OUTGOING CALLS 
button to view all calls that have been placed.  Click on the phone icon to dial the number for a 
particular call log entry. 
 
Refresh All Call Logs 
To refresh all call logs, select the Call Logs tab, and then click the REFRESH button to refresh all 
call logs.   
 
Download Outlook Contacts to SoftPhone 
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To import contacts from Outlook, go to Tools and select Import Outlook Contacts.  This imports 
contacts from Outlook.  
 
Mute 
The Mute button, which is the microphone icon on the right bottom corner of the SoftPhone 
screen, is used to mute or silence the voice of the caller.   
 
You can easily mute your voice during the voice conversation with other parties.  For example, 
party A, B, or C can mute their voice during a call.  If party “A” mutes his/her voice, then “B” and 
“C” will not be able to hear party “A’s” voice.  But party “A” will be able to hear the voices of party 
“B” and “C”.  The same applies to party “B” and “C” if they create the same scenario.  
 
When the mute function is activated, the microphone icon has a red circle with a line through it to 
indicate that mute is “on”.  To deactivate, simply click the microphone icon.  
 
User Status (Manual Answer, Auto Answer, and Do Not Disturb) 
Users can define their status by using this feature, which is available at the bottom of the 
SoftPhone screen beside the microphone icon.  
 
By default, the user status is set to Manual Answer.  When a user receives a call invitation, the 
user has to receive that call manually.  If the user does not want to do this manually, then the 
user can select Auto Answer mode.  All the calls are automatically accepted in the Auto Answer 
mode.  The user can also show the user status as Do Not Disturb which sends callers to voice 
mail (assuming that the voice mail has not been turned off).  
 
Check for Updates 
The user can check if there is an update to the application.  A notification appears on the screen if 
you select Check For Updates from the Tools menu bar.   
 
Shutdown SoftPhone 
To shutdown SoftPhone, go to File > Exit or go to the system tray, right click the SoftPhone icon 
and click quit. 
 
 
 
 
 
 
 
 
 
 
 
 
Uninstall SoftPhone 
To uninstall SoftPhone, go to Start Menu > Programs > Lingo SoftPhone > Lingo SoftPhone 
Uninstaller. 


